• /
  • EnglishEspaรฑolFranรงaisๆ—ฅๆœฌ่ชžํ•œ๊ตญ์–ดPortuguรชs
  • Log inStart now

Force an inventory reset from the infrastructure agent

Problem

The agent is working but some of the metadata or inventory data appears incorrect, and the local caching is preventing correct data to be sent from the infrastructure agent.

Solution Linux

Stop the Infrastructure Agent

bash
$
sudo systemctl stop newrelic-infra

Delete temporary files

bash
$
sudo rm -rf /var/db/newrelic-infra/data

Start the Infrastructure Agent

bash
$
sudo systemctl start newrelic-infra

Solution Windows

In an Administrator PowerShell prompt, stop the Infrastructure Agent

bash
$
net stop newrelic-infra

Delete temporary files

bash
$
Remove-Item -Path โ€œC:\ProgramData\New Relic\newrelic-infra\dataโ€ -Recurse -Force

Start the Infrastructure Agent

bash
$
net start newrelic-infra

Cause

The agent caches metadata & inventory data locally, to determine what delta to send. In some situations, it might be desired to reset this local cache / state, so that all data is sent accross.

Copyright ยฉ 2026 New Relic Inc.

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.